Veeam MP for Hyper-V Reference

 Top Next

This online reference provides basic assistance information for Veeam Management Pack for Microsoft Hyper-V objects and properties, discoveries, rules, monitors and metric definitions.

Objects and Properties

Discoveries

Rules and Monitors

Overrides

Veeam MP for Hyper-V Metric Definitions


Objects and Properties

 Top Previous Next

This section describes Veeam MP for Hyper-V objects and properties.

Veeam Hyper-V Library

Veeam Hyper-V Base Discovery


Veeam Hyper-V Library

Display Name | Object ID | Properties
 |  | Display Name | Key
Hyper-V Cluster (Veeam MP) | Veeam.Virt.Extensions.HyperV.Cluster | Cluster IP Address |
 |  | id | ✓
 |  | Quorum Path |
 |  | Quorum Type |
 |  | Display Name |
Hyper-V Cluster Disk (Veeam MP) | Veeam.Virt.Extensions.HyperV.ClusterDisk | Cluster Name |
 |  | id | ✓
 |  | Owner Node |
 |  | Total Disk Capacity GB |
 |  | Type |
 |  | Display Name |
Hyper-V Cluster Disk Container (Veeam MP) | Veeam.Virt.Extensions.HyperV.ClusterContainer | id | ✓
 |  | Display Name |
Hyper-V Cluster Network Container (Veeam MP) | Veeam.Virt.Extensions.HyperV.ClusterNetworkContainer | id | ✓
 |  | Display Name |
Hyper-V Cluster Shared Volume (Veeam MP) | Veeam.Virt.Extensions.HyperV.ClusteredSharedVolume | Cluster Disk Name |
 |  | Cluster Name |
 |  | Drive Letter / Mount Path |
 |  | FileSystem Type |
 |  | id | ✓
 |  | Total Storage Capacity GB |
 |  | Volume Name |
 |  | Display Name |
Hyper-V Host (Veeam MP) | Veeam.Virt.Extensions.HyperV.ServerRole | BMC Address |
 |  | Build Version |
 |  | Cluster Name |
 |  | CPU Cores |
 |  | CPU Model |
 |  | CPU Sockets |
 |  | Hyper-Threading |
 |  | id | ✓
 |  | Logical Processors |
 |  | Memory GB |
 |  | System BIOS |
 |  | System BIOS Version/Date |
 |  | System Manufacturer |
 |  | System Model |
 |  | System Serial Number |
 |  | Total CPU GHz |
 |  | VMM Name |
 |  | Display Name |
Hyper-V Host Cluster Physical Disk (Veeam MP) | Veeam.Virt.Extensions.HyperV.HostClusterDisk | Disk Id |
 |  | id | ✓
 |  | Total Disk Capacity GB |
 |  | Type |
 |  | Display Name |
Hyper-V Host Disks Container (Veeam MP) | Veeam.Virt.Extensions.HyperV.LocalStorageContainer | hostName |
 |  | id | ✓
 |  | Display Name |
Hyper-V Host Local Physical Disk (Veeam MP) | Veeam.Virt.Extensions.HyperV.LocalDisk | id | ✓
 |  | OS Disk Instance |
 |  | PNP Device Id |
 |  | Total Disk Capacity GB |
 |  | Display Name |
Hyper-V Host Local Volume (Veeam MP) | Veeam.Virt.Extensions.HyperV.LocalStorageVolume | Disk Name |
 |  | Drive Letter / Mount Path |
 |  | FileSystem Type |
 |  | Host Name |
 |  | id | ✓
 |  | Total Storage Capacity GB |
 |  | Volume Name |
 |  | Display Name |
Hyper-V Host Network Container (Veeam MP) | Veeam.Virt.Extensions.HyperV.NetworkAdapterContainer | hostName |
 |  | id | ✓
 |  | Display Name |
Hyper-V Host Physical Network Adapter (Veeam MP) | Veeam.Virt.Extensions.HyperV.pNetworkAdapter | Adapter |
 |  | Duplex |
 |  | Enabled |
 |  | Host Name |
 |  | id | ✓
 |  | IP Address |
 |  | MAC Address |
 |  | Speed Mb |
 |  | Switch Name |
 |  | Display Name |
Hyper-V Host Teamed Physical Network Adapter (Veeam MP) | Veeam.Virt.Extensions.HyperV.TeamedpNetworkAdapter | Adapter |
 |  | Duplex |
 |  | Enabled |
 |  | Host Name |
 |  | id | ✓
 |  | IP Address |
 |  | Load Balancing Algorithm |
 |  | MAC Address |
 |  | Speed Mb |
 |  | Switch Name |
 |  | Teaming Mode |
 |  | Display Name |
Hyper-V Host Virtual Machines Container (Veeam MP) | Veeam.Virt.Extensions.HyperV.VMGuestContainer | hostName |
 |  | id | ✓
 |  | Display Name |
Hyper-V Host Virtual Network Adapter (Veeam MP) | Veeam.Virt.Extensions.HyperV.vNetworkAdapter | Adapter |
 |  | Duplex |
 |  | Enabled |
 |  | Host Name |
 |  | id | ✓
 |  | IP Address |
 |  | MAC Address |
 |  | Speed Mb |
 |  | Switch Name |
 |  | Display Name |
Hyper-V SCVMM Storage Container (Veeam MP) | Veeam.Virt.Extensions.HyperV.VMMStorageContainer | id | ✓
 |  | Display Name |
Hyper-V Virtual Machine (Veeam MP) | Veeam.Virt.Extensions.HyperV.VirtualMachine | Availability |
 |  | Cloud Name |
 |  | Cluster name |
 |  | Clustered Role Name |
 |  | CPU Count |
 |  | CPU Priority |
 |  | CPU Reservation |
 |  | Disk Allocation GB |
 |  | Disk IOPS Limit |
 |  | Generation |
 |  | Guest DNS Name |
 |  | Guest OS |
 |  | Guest Service Version |
 |  | Host Name |
 |  | id | ✓
 |  | Integration Services Offered |
 |  | IP Address(es) |
 |  | Last Successful Backup |
 |  | Memory Buffer |
 |  | Memory Dynamic |
 |  | Memory Maximum MB |
 |  | Memory Minimum MB |
 |  | Memory Startup MB |
 |  | Memory Weight |
 |  | Uses Networks |
 |  | Uses Storage |
 |  | Version |
 |  | Video Adapter |
 |  | Virtual NUMA Spanning |
 |  | VM Name |
 |  | VMM Name |
 |  | Display Name |
Hyper-V Virtual Switch (Veeam MP) | Veeam.Virt.Extensions.HyperV.vSwitch | Host Name |
 |  | id | ✓
 |  | Logical Switch ID |
 |  | Type |
 |  | VLAN ID |
 |  | Display Name |
Veeam Hyper-V | Veeam.Virt.Extensions.HyperV.Base | Display Name |
Veeam Hyper-V Cluster Disks Group | Veeam.Virt.Extensions.HyperV.ClusterDisk.Group | Display Name |
Veeam Hyper-V Cluster Shared Volumes Group | Veeam.Virt.Extensions.HyperV.Storage.Group | Display Name |
Veeam Hyper-V Clusters Group | Veeam.Virt.Extensions.HyperV.Cluster.Group | Display Name |
Veeam Hyper-V Compute Topology Root Group | Veeam.Virt.Extensions.HyperV.ComputeTopologyRoot.Group | Display Name |
Veeam Hyper-V Hosts Group | Veeam.Virt.Extensions.HyperV.Host.Group | Display Name |
Veeam Hyper-V Network Topology Root Group | Veeam.Virt.Extensions.HyperV.NetworkTopologyRoot.Group | Display Name |
Veeam Hyper-V Storage Topology Root Group | Veeam.Virt.Extensions.HyperV.StorageTopologyRoot.Group | Display Name |
Veeam Hyper-V Virtual Machines Group | Veeam.Virt.Extensions.HyperV.VirtualMachine.Group | Display Name |
Veeam Hyper-V Virtual Switches Group | Veeam.Virt.Extensions.HyperV.vSwitch.Group | Display Name |


Veeam Hyper-V Base Discovery

Display Name | Object ID | Properties
 |  | Display Name | Key
Hyper-V Discovery Target (Veeam MP) | Veeam.Virt.Extensions.HyperV.Stub | Cluster Name |
 |  | Host Name |
 |  | id | ✓
 |  | Reserved |
 |  | Sockets |
 |  | State |
 |  | VMM Name |
 |  | Display Name |
Hyper-V SCVMM Server (Veeam MP) | Veeam.Virt.Extensions.HyperV.SCVMMServer | id | ✓
 |  | Version |
 |  | Display Name |
Hyper-V Virtualization Extensions Object (Veeam MP) | Veeam.Virt.Extensions.HyperV.HyperVVirtualMachine | Availability |
 |  | Cluster name |
 |  | CPU Count |
 |  | CPU Priority |
 |  | CPU Reservation |
 |  | Disk Allocation GB |
 |  | Guest OS |
 |  | Guest OS FQDN |
 |  | Guest OS NETBIOS Name |
 |  | Guest Service Version |
 |  | Host Name |
 |  | Memory Buffer |
 |  | Memory Dynamic |
 |  | Memory Maximum MB |
 |  | Memory Minimum MB |
 |  | Memory Startup MB |
 |  | Memory Weight |
 |  | Uses Networks |
 |  | Uses Storage |
 |  | Virtual NUMA Spanning |
 |  | Virtualization Platform |
 |  | VM Id |
 |  | VM Version |
 |  | VMM Name |
 |  | Display Name |
Veeam Ops Mgr agents running in Hyper-V VMs | Veeam.Virt.Extensions.HyperV.HyperVVirtualMachine.Group | Display Name |


Discoveries

This section describes Veeam MP for Hyper-V discoveries.

Veeam Hyper-V Base Discovery

Veeam Hyper-V Discovery


Veeam Hyper-V Base Discovery

Display Name | Discovery ID | Properties
 |  | Object Name | Property ID | Display Name
Veeam Hyper-V Base SCVMM Server discovery | Veeam.Virt.Extensions.HyperV.BaseSCVMMDiscovery | Hyper-V SCVMM Server (Veeam MP) | PrincipalName |
 |  |  | id | id
 |  |  | Version | Version
Veeam Hyper-V Discovery Target Object Initial Discovery | Veeam.Virt.Extensions.HyperV.Stub.Discovery | Hyper-V Discovery Target (Veeam MP) | id | id
 |  |  | HostName | Host Name
 |  |  | ClusterName | Cluster Name
 |  |  | Sockets | Sockets
Veeam Hyper-V Virtual Machine Discovery | Veeam.Virt.Extensions.HyperV.HyperVVirtualMachine.Discovery | Hyper-V Virtualization Extensions Object (Veeam MP) | DisplayName |
 |  |  | virtPlatform | Virtualization Platform
 |  |  | GuestOSDNSName | Guest OS FQDN
 |  |  | GuestOSNetBIOSName | Guest OS NETBIOS Name
 |  |  | VmId | VM Id
Veeam Virtualization Extensions for System Center Topology discovery | Veeam.Virt.Extensions.VMware.EMTopology.Discovery | Veeam Virtualization Extensions Service | licSocketsHyperV | Licensed Hyper-V Sockets


Veeam Hyper-V Discovery

Display Name | Discovery ID | Properties
 |  | Object Name | Property ID | Display Name
Create relationship between Hyper-V virtual machine and Ops Mgr Agent in VM | Veeam.Virt.Extensions.HyperV.Integration.SDK.VMContainsWC.Discovery | Hyper-V Virtual Machine (Veeam MP) | id | id
Veeam Hyper-V Cluster Shared Volume discovery | Veeam.Virt.Extensions.HyperV.ClusterSharedVolumeDiscovery | Hyper-V Cluster Disk (Veeam MP) | id | id
 |  |  | OwnerNode | Owner Node
 |  |  | ClusterName | Cluster Name
 |  |  | CapacityGB | Total Disk Capacity GB
 |  |  | Type | Type
 |  | Hyper-V Cluster Shared Volume (Veeam MP) | id | id
 |  |  | DriveLetter | Drive Letter / Mount Path
 |  |  | ClusterName | Cluster Name
 |  |  | CapacityGB | Total Storage Capacity GB
 |  |  | FileSystemType | FileSystem Type
Veeam Hyper-V Host Network Adapter discovery | Veeam.Virt.Extensions.HyperV.NetworkAdapterDiscovery | Hyper-V Host Physical Network Adapter (Veeam MP) | id | id
 |  |  | HostName | Host Name
 |  |  | AdapterName | Adapter
 |  |  | Duplex | Duplex
 |  |  | SpeedMb | Speed Mb
 |  |  | MACAddress | MAC Address
 |  |  | IPAddress | IP Address
 |  |  | SwitchName | Switch Name
 |  |  | Enabled | Enabled
 |  | Hyper-V Host Virtual Network Adapter (Veeam MP) | id | id
 |  |  | HostName | Host Name
 |  |  | AdapterName | Adapter
 |  |  | Duplex | Duplex
 |  |  | SpeedMb | Speed Mb
 |  |  | MACAddress | MAC Address
 |  |  | IPAddress | IP Address
 |  |  | SwitchName | Switch Name
 |  |  | Enabled | Enabled
 |  | Hyper-V Host Teamed Physical Network Adapter (Veeam MP) | id | id
 |  |  | HostName | Host Name
 |  |  | AdapterName | Adapter
 |  |  | Duplex | Duplex
 |  |  | SpeedMb | Speed Mb
 |  |  | MACAddress | MAC Address
 |  |  | IPAddress | IP Address
 |  |  | SwitchName | Switch Name
 |  |  | Enabled | Enabled
 |  |  | LoadBalancingAlgorithm | Load Balancing Algorithm
 |  |  | TeamingMode | Teaming Mode
 |  | Hyper-V Virtual Switch (Veeam MP) | id | id
 |  |  | HostName | Host Name
 |  |  | Type | Type
 |  |  | VLANID | VLANID
Veeam Hyper-V SCVMM properties and relations discovery | Veeam.Virt.Extensions.HyperV.PropertiesSCVMMDiscovery | Hyper-V Cluster (Veeam MP) | ClusterName | id
 |  | Hyper-V Host (Veeam MP) | PrincipalName |
 |  |  | id | id
 |  |  | VMMName | VMM Name
 |  | Hyper-V SCVMM Storage Container (Veeam MP) | id | id
Veeam Hyper-V SCVMM Virtual Machine discovery | Veeam.Virt.Extensions.HyperV.VMsinSCVMMDiscovery | Hyper-V Virtual Machine (Veeam MP) | id | id
 |  |  | VMMName | VMM Name
 |  |  | CloudName | Cloud Name
 |  |  | GuestOS | Guest OS
 |  |  | GuestServiceVersion | Guest Service Version
 |  |  | guestHostName | Guest DNS Name
Veeam Hyper-V Server Role discovery | Veeam.Virt.Extensions.HyperV.2012.ServerRoleDiscovery | Hyper-V Host (Veeam MP) | id | id
 |  |  | Version | Build Version
 |  |  | MemoryGB | Memory GB
 |  |  | CPUModel | CPU Model
 |  |  | CPUSockets | CPU Sockets
 |  |  | CPUCores | CPU Cores
 |  |  | TotalCPUGHz | Total CPU GHz
 |  |  | ClusterName | Cluster Name
 |  |  | SystemManufacturer | System Manufacturer
 |  |  | SystemModel | System Model
 |  |  | SystemBIOS | System BIOS
 |  |  | SystemSerialNumber | System Serial Number
 |  | Hyper-V Cluster (Veeam MP) | ClusterName | id
 |  |  | ClusterIP | Cluster IP Address
 |  |  | QuorumType | Quorum Type
 |  |  | QuorumPath | Quorum Path
 |  | Hyper-V Host Virtual Machines Container (Veeam MP) | id | id
 |  |  | hostName | hostName
Veeam Hyper-V Storage discovery | Veeam.Virt.Extensions.HyperV.ClusterDiskDiscovery | Hyper-V Cluster Disk (Veeam MP) | id | id
 |  |  | OwnerNode | Owner Node
 |  |  | ClusterName | Cluster Name
 |  |  | CapacityGB | Total Disk Capacity GB
 |  |  | Type | Type
 |  | Hyper-V Host Cluster Physical Disk (Veeam MP) | id | id
 |  |  | diskid | Disk Id
 |  |  | CapacityGB | Total Disk Capacity GB
 |  |  | PNPDeviceid |
 |  |  | Type | Type
 |  | Hyper-V Cluster Shared Volume (Veeam MP) | id | id
 |  |  | DriveLetter | Drive Letter / Mount Path
 |  |  | ClusterName | Cluster Name
 |  |  | CapacityGB | Total Disk Capacity GB
 |  |  | FileSystemType | FileSystem Type
Veeam Hyper-V Virtual Machine discovery | Veeam.Virt.Extensions.HyperV.VirtualMachineDiscovery | Hyper-V Virtual Machine (Veeam MP) | id | id
 |  |  | VMName | VM Name
 |  |  | HostName | Host Name
 |  |  | Availability | Availability
 |  |  | Clustername | Cluster name
 |  |  | MemWeight | Memory Weight
 |  |  | MemDynamic | Memory Dynamic
 |  |  | MaxMem | Memory Maximum MB
 |  |  | MinMem | Memory Minimum MB
 |  |  | StartMem | Memory Startup MB
 |  |  | CPUCount | CPU Count
 |  |  | CPUWeight | CPU Priority
 |  |  | CPUReservation | CPU Reservation
 |  |  | MemBuffer | Memory Buffer
 |  |  | DiskAllocationGB | Disk Allocation GB
 |  |  | VMVersion | Version
 |  |  | VirtualNUMASpanning | Virtual NUMA Spanning
 |  |  | UsesStorage | Uses Storage
 |  |  | UsesNetworks | Uses Networks
Veeam Hyper-V Virtual Machine properties discovery | Veeam.Virt.Extensions.HyperV.VMPropertiesDiscovery | Hyper-V Virtual Machine (Veeam MP) | id | id
 |  |  | Generation | Generation
 |  |  | GuestServiceVersion | Guest Service Version
 |  |  | UsesNetworks | Uses Networks
 |  |  | IPAddresses | IP Address(es)
 |  |  | IntegrationServicesOffered | Integration Services Offered
 |  |  | VideoAdapter | Video Adapter
 |  |  | GuestOS | Guest OS
 |  |  | guestHostName | Guest DNS Name
 |  | Hyper-V Virtual Switch (Veeam MP) | id | id
Veeam Hyper-V vSwitch properties discovery | Veeam.Virt.Extensions.HyperV.vSwitchPropertiesDiscovery | Hyper-V Virtual Switch (Veeam MP) | id | id
 |  |  | Type | Type
 |  |  | VLANID | VLANID
 |  | Hyper-V Host Network Container (Veeam MP) | id | id


Rules and Monitors

This section described Veeam MP for Hyper-V rules and monitors.

Performance Monitors

Performance Collection Rules

Event-Based Rules

Event Monitors

Dependency Monitors


Performance Monitors

Target | Monitor/Alert Name | Threshold (Warning) | Threshold (Error) | Enabled | Overrides
Hyper-V Cluster (Veeam MP) | Veeam HyperV: Cluster CPU Usage | 80 | 90 | yes | no
Hyper-V Cluster (Veeam MP) | Veeam HyperV: Cluster Memory Usage | 80 | 90 | yes | no
Hyper-V Cluster Disk (Veeam MP) | Veeam HyperV: Cluster Disk Latency Analysis | 40 | 80 | yes | no
Hyper-V Cluster Shared Volume (Veeam MP) | Veeam HyperV: Cluster Volume Free Space | 10 | 5 | yes | no
Hyper-V Host (Veeam MP) | Veeam HyperV: Host CPU Usage Analysis | 80 | 90 | yes | no
Hyper-V Host (Veeam MP) | Veeam HyperV: Host Memory Pages/sec | 800 | 1000 | yes | no
Hyper-V Host (Veeam MP) | Veeam HyperV: Host Memory Usage Analysis | 90 | 95 | yes | no
Hyper-V Host Local Physical Disk (Veeam MP) | Veeam HyperV: Host Local Disk Latency Analysis | 40 | 80 | yes | no
Hyper-V Host Local Volume (Veeam MP) | Veeam HyperV: Local Volume Free Space | 10 | 5 | yes | no
Hyper-V Host Physical Network Adapter (Veeam MP) | Veeam HyperV: Host Network Queue Length | 2 | 3 | yes | no
Hyper-V Host Virtual Network Adapter (Veeam MP) | Veeam HyperV: Host Network Queue Length | 2 | 3 | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam HyperV: VM Checkpoint Analysis | 2048 (MB) 48 (hours) | - | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam HyperV: VM CPU Usage | 80 | 95 | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam HyperV: VM Memory Pressure Analysis | 100 | 120 | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam HyperV: VM Storage Errors | 0 | - | yes | no


Performance Collection Rules

This section describes Veeam MP for Hyper-V performance collection rules.

Veeam Hyper-V Base Discovery

Veeam Hyper-V Monitoring


Veeam Hyper-V Base Discovery

Target | Rule/Alert Name | Metric Class | Metric Name | Object Name | Counter Name | Data Warehouse | Enabled | Overrides
Hyper-V Virtualization Extensions Object (Veeam MP) | Veeam Virtualization Extensions Object Performance Collection Rule - % Disk Time |  |  | LogicalDisk | % Disk Time | yes | yes | no
Hyper-V Virtualization Extensions Object (Veeam MP) | Veeam Virtualization Extensions Object Performance Collection Rule - % Memory Used (_Total) |  |  | VMGuest-memory | % Memory Used | yes | yes | no
Hyper-V Virtualization Extensions Object (Veeam MP) | Veeam Virtualization Extensions Object Performance Collection Rule - % Network bandwidth used |  |  | VMGuest-net | % Bandwidth Used | yes | yes | no
Hyper-V Virtualization Extensions Object (Veeam MP) | Veeam Virtualization Extensions Object Performance Collection Rule - % Page File Used (_Total) |  |  | Paging File | % Usage | yes | yes | no
Hyper-V Virtualization Extensions Object (Veeam MP) | Veeam Virtualization Extensions Object Performance Collection Rule - % Processor Time (_Total) |  |  | Processor | % Processor Time | yes | yes | no
Hyper-V Virtualization Extensions Object (Veeam MP) | Veeam Virtualization Extensions Object Performance Collection Rule - memory pages/sec (_Total) |  |  | Memory | Pages/sec | yes | yes | no


Veeam Hyper-V Monitoring

Target | Rule/Alert Name | Object Name | Counter Name | Data Warehouse | Enabled | Overrides
Hyper-V Cluster (Veeam MP) | Veeam Hyper-V Cluster CPU Used % | Hyper-V Cluster | CPU Used % | yes | yes | no
Hyper-V Cluster (Veeam MP) | Veeam Hyper-V Cluster Memory Used % | Hyper-V Cluster | Memory Used % | yes | yes | no
Hyper-V Cluster Disk (Veeam MP) | Veeam Hyper-V Cluster Disk Highest Latency | Cluster CSV File System | Highest Latency | yes | yes | no
Hyper-V Cluster Disk (Veeam MP) | Veeam Hyper-V Cluster Disk IOPS | Cluster CSV File System | IOPS | yes | yes | no
Hyper-V Cluster Disk (Veeam MP) | Veeam Hyper-V Cluster Disk Usage MB/s | Cluster CSV File System | Usage MB/s | yes | yes | no
Hyper-V Cluster Shared Volume (Veeam MP) | Veeam Hyper-V CSV Free Space % | Cluster CSV File System | Free Space % | yes | yes | no
Hyper-V Cluster Shared Volume (Veeam MP) | Veeam Hyper-V CSV Free Space GB | Cluster CSV File System | Free Space GB | yes | yes | no
Hyper-V Host (Veeam MP) | Veeam Hyper-V Host Context Switches/sec | System | Context Switches/sec | yes | yes | no
Hyper-V Host (Veeam MP) | Veeam Hyper-V Host CPU Usage MHz | Hyper-V Hypervisor Logical Processor | CPU Usage MHz | yes | yes | no
Hyper-V Host (Veeam MP) | Veeam Hyper-V Host Memory Balancer Available Memory | Hyper-V Dynamic Memory Balancer | Available Memory | yes | yes | no
Hyper-V Host (Veeam MP) | Veeam Hyper-V Host Memory Pages/sec | Memory | Pages/sec | yes | yes | no
Hyper-V Host (Veeam MP) | Veeam Hyper-V Host Memory Pressure % | Hyper-V Dynamic Memory Balancer | Average Pressure | yes | yes | no
Hyper-V Host (Veeam MP) | Veeam Hyper-V Host Memory Used % | Memory | Memory Used % | yes | yes | no
Hyper-V Host (Veeam MP) | Veeam Hyper-V Host Memory Used MB | Memory | Memory Used MB | yes | yes | no
Hyper-V Host (Veeam MP) | Veeam Hyper-V Host Number of Virtual Processors | Hyper-V Hypervisor | Virtual Processors | yes | yes | no
Hyper-V Host (Veeam MP) | Veeam Hyper-V Host Processor Queue Length | System | Processor Queue Length | yes | yes | no
Hyper-V Host (Veeam MP) | Veeam Hyper-V Host Virtual Processor % Hypervisor Run Time | Hyper-V Hypervisor Logical Processor | % Hypervisor Run Time | yes | yes | no
Hyper-V Host (Veeam MP) | Veeam Hyper-V Host Virtual Processor % Total Run Time | Hyper-V Hypervisor Logical Processor | % Total Run Time | yes | yes | no
Hyper-V Host (Veeam MP) | Veeam Hyper-V Host VM Paused | Hyper-V Hypervisor | VM Paused | yes | yes | no
Hyper-V Host (Veeam MP) | Veeam Hyper-V Host VM Powered Off | Hyper-V Hypervisor | VM Powered Off | yes | yes | no
Hyper-V Host (Veeam MP) | Veeam Hyper-V Host VM Running | Hyper-V Hypervisor | VM Running | yes | yes | no
Hyper-V Host (Veeam MP) | Veeam Hyper-V Host VM Saved | Hyper-V Hypervisor | VM Saved | yes | yes | no
Hyper-V Host (Veeam MP) | Veeam Hyper-V Host VM Total | Hyper-V Hypervisor | VM Total | yes | yes | no
Hyper-V Host Cluster Physical Disk (Veeam MP) | Veeam Hyper-V Disk IOPS | Cluster CSV File System | IOPS | yes | yes | no
Hyper-V Host Cluster Physical Disk (Veeam MP) | Veeam Hyper-V Disk Read Latency | Cluster CSV File System | Read Latency ms | yes | yes | no
Hyper-V Host Cluster Physical Disk (Veeam MP) | Veeam Hyper-V Disk Usage MB/s | Cluster CSV File System | Usage MB/s | yes | yes | no
Hyper-V Host Cluster Physical Disk (Veeam MP) | Veeam Hyper-V Disk Write Latency | Cluster CSV File System | Write Latency ms | yes | yes | no
Hyper-V Host Local Physical Disk (Veeam MP) | Veeam Hyper-V Host Local Disk IOPS | PhysicalDisk | Disk Transfers/sec | yes | yes | no
Hyper-V Host Local Physical Disk (Veeam MP) | Veeam Hyper-V Host Local Disk Latency | PhysicalDisk | Avg. Disk sec/Transfer | yes | yes | no
Hyper-V Host Local Physical Disk (Veeam MP) | Veeam Hyper-V Host Local Disk Usage MB/s | PhysicalDisk | Disk Bytes/sec | yes | yes | no
Hyper-V Host Local Volume (Veeam MP) | Veeam Hyper-V Local Volume Free Space % | Local File System | Free Space % | yes | yes | no
Hyper-V Host Local Volume (Veeam MP) | Veeam Hyper-V Local Volume Free Space GB | Local File System | Free Space GB | yes | yes | no
Hyper-V Host Physical Network Adapter (Veeam MP) | Veeam Hyper-V Host Physical Network Adapter Output Queue Length | Network Interface | Output Queue Length | yes | yes | no
Hyper-V Host Virtual Network Adapter (Veeam MP) | Veeam Hyper-V Host Virtual Network Adapter Output Queue Length | Network Interface | Output Queue Length | yes | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam Hyper-V Dynamic Memory VM Physical Memory | Hyper-V Dynamic Memory VM | Physical Memory | yes | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam Hyper-V VM Checkpoint Age | Hyper-V VM Checkpoints | Age Hours | yes | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam Hyper-V VM Checkpoint Size | Hyper-V VM Checkpoints | Size MB | yes | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam Hyper-V VM Guest Visible Physical Memory | Hyper-V Dynamic Memory VM | Guest Visible Physical Memory | yes | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam Hyper-V VM Memory Average Pressure % | Hyper-V Dynamic Memory VM | Average Pressure | yes | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam Hyper-V VM Storage Commands per Second | Hyper-V Virtual Storage Device | Commands per second | yes | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam Hyper-V VM Storage Error Count | Hyper-V Virtual Storage Device | Error Count | yes | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam Hyper-V VM Storage Error Count (_Total) | Hyper-V Virtual Storage Device | Error Count | yes | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam Hyper-V VM Storage Flush Count | Hyper-V Virtual Storage Device | Flush Count | yes | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam Hyper-V VM Total Disk KB/sec | Hyper-V Virtual Storage Device | KB Total/sec | yes | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam Hyper-V VM Total Network KB/sec | Hyper-V Virtual Network Adapter | KB Total/sec | yes | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam Hyper-V VM Used Storage GB | Hyper-V Virtual Storage Device | Used Storage GB | yes | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam Hyper-V VM Used Storage GB (per-disk) | Hyper-V Virtual Storage Device | Used Storage GB | yes | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam Hyper-V VM Virtual Processor % Guest Run Time | Hyper-V Hypervisor Virtual Processor | % Guest Run Time | yes | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam Hyper-V VM Virtual Processor % Hypervisor Run Time | Hyper-V Hypervisor Virtual Processor | % Hypervisor Run Time | yes | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam Hyper-V VM Virtual Processor % Total Run Time | Hyper-V Hypervisor Virtual Processor | % Total Run Time | yes | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam Hyper-V VM Virtual Processor CPU Usage MHz | Hyper-V Hypervisor Virtual Processor | Usage MHz | yes | yes | no


Event Monitors

This section describes Veeam MP for Hyper-V event monitors.

Veeam Hyper-V Base Discovery

Veeam Hyper-V Monitoring


Veeam Hyper-V Base Discovery

Event Monitors

Target | Monitor/Alert Name | Warning event ID | Error event ID | Close Event ID | Enabled | Overrides
Veeam Virtualization Extensions Service | Veeam HyperV: Licensed socket count exceeded |  | EventDisplayNumber Equal 1106 | EventDisplayNumber Equal 1105 | yes | no


Veeam Hyper-V Monitoring

Event Monitors

Target | Monitor/Alert Name | Warning event ID | Error event ID | Close Event ID | Enabled | Overrides
Hyper-V Cluster Disk (Veeam MP) | Veeam HyperV: Cluster Storage Status |  |  |  | yes | no
Hyper-V Host Cluster Physical Disk (Veeam MP) | Veeam HyperV: Host Cluster Disk Status |  |  |  | yes | yes
Hyper-V Host Network Container (Veeam MP) | Veeam HyperV: Host Network connectivity problem |  |  |  | yes | no
Hyper-V Host Physical Network Adapter (Veeam MP) | Veeam HyperV: Network Adapter Status |  |  |  | yes | yes
Hyper-V Host Teamed Physical Network Adapter (Veeam MP) | Veeam HyperV: Network Adapter Team Status |  |  |  | yes | yes
Hyper-V Virtual Machine (Veeam MP) | Veeam HyperV: VM Cluster Resource Status |  |  |  | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam HyperV: VM Health |  |  |  | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam HyperV: VM Heartbeat |  |  |  | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam HyperV: VM Integration Services Status |  |  |  | yes | no
Hyper-V Virtual Machine (Veeam MP) | Veeam HyperV: VM Power State |  |  |  | yes | yes
Hyper-V Virtual Switch (Veeam MP) | Veeam HyperV: Network connectivity problem on Host Virtual Switch |  |  |  | yes | no
Veeam Virtualization Extensions Service | Veeam HyperV: SCVMM Connection Account (Read-only) configuration state |  |  |  | yes | no


Event-Based Rules

Target | Rule/Alert Name | Event ID | Alert Level | Enabled | Overrides
Hyper-V Host Virtual Machines Container (Veeam MP) | Veeam HyperV: VM Backup Error |  | Error | yes | no
Hyper-V Host Virtual Machines Container (Veeam MP) | Veeam HyperV: VM Guest OS Error | 18590 | Error | yes | no
Hyper-V Host Virtual Machines Container (Veeam MP) | Veeam HyperV: VM NUMA Error |  | Error | yes | no
Hyper-V Host Virtual Machines Container (Veeam MP) | Veeam HyperV: VM RemoteFX Error |  | Error | yes | no


Dependency Monitors

Target | Monitor/Alert Name | Category | Parent Monitor | Member Monitor | Enabled | Overrides
Hyper-V Host (Veeam MP) | Rollup Veeam Hyper-V Host Disk Container Performance State to Hyper-V Host | Performance | Performance | Performance | yes | no
Hyper-V Host (Veeam MP) | Rollup Veeam Hyper-V Host Disk Container State to Hyper-V Host | Availability | Availability | Availability | yes | no
Hyper-V Host (Veeam MP) | Rollup Veeam Hyper-V Host Network Container Performance State to Hyper-V Host | Performance | Performance | Performance | yes | no
Hyper-V Host (Veeam MP) | Rollup Veeam Hyper-V Host Network Container State to Hyper-V Host | Availability | Availability | Availability | yes | no
Hyper-V Host Disks Container (Veeam MP) | Rollup Veeam Hyper-V Host Cluster Disk State to Host Disk Container | Availability | Availability | Availability | yes | no
Hyper-V Host Disks Container (Veeam MP) | Rollup Veeam Hyper-V Host Local Disk Performance State to Host Disk Container | Performance | Performance | Performance | yes | no
Hyper-V Host Network Container (Veeam MP) | Rollup Veeam Hyper-V Host Physical NIC Performance State to Network Container | Performance | Performance | Performance | yes | no
Hyper-V Host Network Container (Veeam MP) | Rollup Veeam Hyper-V Host Virtual NIC Performance State to Network Container | Performance | Performance | Performance | yes | no
Hyper-V Host Virtual Machines Container (Veeam MP) | Rollup Veeam Hyper-V VM Availability State to VM Container | Availability | Availability | Availability | yes | no
Hyper-V Host Virtual Machines Container (Veeam MP) | Rollup Veeam Hyper-V VM Performance State to VM Container | Performance | Performance | Performance | yes | no


Overrides

Override ID | Object Name | Context | Property | Value
Veeam.Virt.Extensions.HyperV.HostClusterDisk.Monitor.State.DisableAlert | Veeam HyperV: Host Cluster Disk Status | Hyper-V Host Cluster Physical Disk (Veeam MP) | GenerateAlert | false
Veeam.Virt.Extensions.HyperV.TeamedNetworkAdapter.DisableAlert | Veeam HyperV: Network Adapter Team Status | Hyper-V Host Teamed Physical Network Adapter (Veeam MP) | GenerateAlert | false
Veeam.Virt.Extensions.HyperV.NetworkAdapter.DisableAlert | Veeam HyperV: Network Adapter Status | Hyper-V Host Physical Network Adapter (Veeam MP) | GenerateAlert | false
Veeam.Virt.Extensions.HyperV.VM.Monitor.Uptime.DisableAlert | Veeam HyperV: VM Power State | Hyper-V Virtual Machine (Veeam MP) | GenerateAlert | false


Veeam MP for Hyper-V Metric Definitions

This section describes performance metrics collected from Hyper-V systems and unique Veeam MP for Microsoft Hyper-V metrics.

Cluster

Cluster Disk

Clustered Shared Volume

Host Cluster Physical Disk

Host Local Physical Disk

Host Local Volume

Host

Virtual Machine

Guest OS


Cluster

Object | Counter | Instance | Definition
Hyper-V Cluster | CPU Used % | _Total | The average of the physical CPU usage of each Hyper-V host in the cluster. For example, if a cluster was composed of 2 hosts and CPU values were 50% and 60%, then this value would show 55%.
Hyper-V Cluster | Memory Used % | _Total | Ratio of the sum of cluster physical memory usage and memory overhead for all VMs in the cluster compared to the amount of memory available in the cluster, expressed as a percentage.


Cluster Disk

Object | Counter | Instance | Definition
Cluster CSV File System | Highest Latency | _Total | The highest latency for completing read and write requests on the disk.
Cluster CSV File System | IOPS | _Total | Total number of read and write requests that were queued for the selected disk.
Cluster CSV File System | Usage MB/s | _Total | Rate at which bytes are transferred to and from the disk during read/write operations.


Clustered Shared Volume

Object | Counter | Instance | Definition
Cluster CSV File System | Free Space GB | _Total | The amount of free space (in GB) on the volume.
Cluster CSV File System | Free Space % | _Total | The amount of free space (in percentage) on the volume.


Host Cluster Physical Disk

Object | Counter | Instance | Definition
Cluster CSV File System | Read Latency ms | _Total | The average latency between the time a read request arrived to the file system and the time when it was completed.
Cluster CSV File System | Write Latency ms | _Total | The average latency between the time a write request arrived to the file system and the time when it was completed.
Cluster CSV File System | IOPS | _Total | Total number of read and write requests that were queued for the selected volume.
Cluster CSV File System | Usage MB/s | _Total | Rate at which bytes were read from and written to the volume.


Host Local Physical Disk

Object | Counter | Instance | Definition
Local Disk | Latency | _Total | The latency for completing read and write requests queued for the selected disk.
Local Disk | IOPS | _Total | Total number of read and write requests that were queued for the selected disk.
Local Disk | Usage MB/s | _Total | Rate at which bytes are transferred to and from the disk during read/write operations.


Host Local Volume

Object | Counter | Instance | Definition
Local File System | Free Space GB | _Total | The amount of free space (in GB) on the local file system volumes.
Local File System | Free Space % | _Total | The amount of free space (in percentage) on the local file system volumes.


Host

Object | Counter | Instance | Definition
Hyper-V Dynamic Memory Balancer | Available Memory | _Total | The amount of memory that the Hyper-V Dynamic Memory Balancer can assign to virtual machines.
Hyper-V Dynamic Memory Balancer | Average Pressure % | _Total | Average memory pressure for all virtual machines across the Hyper-V host.
Hyper-V Hypervisor | Virtual Processors | _Total | The number of virtual processors configured for all VMs running on the Hyper-V host.
Hyper-V Hypervisor | VM Total | _Total | Total number of virtual machines registered on the Hyper-V host.
Hyper-V Hypervisor | VM Running | _Total | Number of powered on virtual machines on the Hyper-V host.
Hyper-V Hypervisor | VM Powered Off | _Total | Number of virtual machines in the shutdown (powered off) state on the Hyper-V host.
Hyper-V Hypervisor | VM Paused | _Total | Number of virtual machines in the paused (suspended) state on the Hyper-V host.
Hyper-V Hypervisor | VM Saved | _Total | Number of virtual machines in the saved state on the Hyper-V host.
Hyper-V Hypervisor Logical Processor | % Hypervisor Run Time | _Total | Percentage of physical processor time used to run the hypervisor.
Hyper-V Hypervisor Logical Processor | % Total Run Time | _Total | Percentage of physical processor time used to run both VMs and the hypervisor.
Hyper-V Hypervisor Logical Processor | CPU Usage MHz | _Total | The current CPU usage for the Hyper-V server (in MHz).
Memory | Memory Used MB | _Total | Physical memory usage on the Hyper-V host in MB.
Memory | Memory Used % | _Total | Memory used divided by total physical memory, as a percentage.
Memory | Pages/sec | _Total | Rate at which pages are read from or written to disk to resolve hard page faults. This counter is a primary indicator of the kinds of faults that cause system-wide delays.
System | Context Switches/sec | _Total | The number of times a virtual processor had been scheduled to a particular logical processor.
System | Processor Queue Length | _Total | The number of threads that are currently queued up and waiting to be executed on the processor.

Host NET

Object | Counter | Instance | Definition
Hyper-V Network Adapter | Output Queue Length | AdapterName | Length of the output queue (in packets). If the Output Queue Length is longer than 2, there are delays and the bottleneck should be found and eliminated, if possible.


Virtual Machine

Object | Counter | Instance | Definition
Hyper-V Dynamic Memory VM | Average Pressure % | _Total | The amount of memory the VM requires compared to the amount of memory currently allocated to the VM.
Hyper-V Dynamic Memory VM | Guest Visible Physical Memory MB | _Total | The amount of memory visible to a guest OS running inside the VM.
Hyper-V Dynamic Memory VM | Physical Memory MB | _Total | Current amount of memory in the VM.
Hyper-V Dynamic Memory VM | % Guest Run Time | _Total | Percentage of physical processor time consumed by the VM.
Hyper-V Hypervisor Virtual Processor | % Hypervisor Run Time | _Total | Percentage of physical processor time consumed by the Hyper-V host to run the VM.
Hyper-V Hypervisor Virtual Processor | % Total Run Time | _Total | Percentage of physical processor time consumed by the Hyper-V host to run the VM and processor time consumed by the VM itself.
Hyper-V Hypervisor Virtual Processor | Usage MHz | _Total | The current CPU usage for the virtual processor (in MHz).
Hyper-V Virtual Network Adapter | Total Network KB/sec | _Total | Rate at which bytes have been sent and received per second to the network.
Hyper-V Virtual Storage Device | Total Disk KB/sec | _Total | Rate at which bytes have been read and written per second on the virtual device.
Hyper-V Virtual Storage Device | Error Count | _Total | Total number of errors that have occurred on the virtual machine.
Hyper-V Virtual Storage Device | Error Count | InstanceName | Total number of errors that have occurred on the virtual device.
Hyper-V Virtual Storage Device | Flush Count | _Total | Total number of flush operations that have occurred on the virtual machine.
Hyper-V Virtual Storage Device | Flush Count | InstanceName | Total number of flush operations that have occurred on the virtual device.
Hyper-V Virtual Storage Device | Commands per second | _Total | Number of input/output operations per second, calculated as total of reads and writes and divided by the collection interval.
Hyper-V Virtual Storage Device | Used Storage GB | _Total | Total storage space (in GB) committed to the virtual machine across all virtual devices.
Hyper-V Virtual Storage Device | Used Storage GB | InstanceName | Storage space (in GB) committed to the virtual machine on the virtual device.
Hyper-V VM Checkpoints | Checkpoint Size MB | _Total | Total size of snapshot files for the VM.
Hyper-V VM Checkpoints | Checkpoint Age Hours | _Total | The age of the oldest snapshot.

Host NET

Object | Counter | Instance | Definition
Hyper-V Network Adapter | Output Queue Length | AdapterName | Length of the output queue (in packets). If the Output Queue Length is longer than 2, there are delays and the bottleneck should be found and eliminated, if possible.


Guest OS

 Top Previous
Object | Counter | Instance | Definition
VMGuest-cpu | % Processor Time | _Total | Percentage of elapsed time that the processor spends to execute a non-Idle thread of guest OS.
VMGuest-disk | % Disk Time | _Total | Percentage of elapsed time that the guest disk drives were busy servicing read or write requests.
VMGuest-memory | % Memory Used | _Total | Physical memory in use. Total physical memory – memory immediately available for allocation to a process or for system use.
VMGuest-memory | Pages/sec | _Total | Rate at which pages are read from or written to disk to resolve hard page faults. This counter is a primary indicator of the kinds of faults that cause system-wide delays.
VMGuest-memory | % Page File Used | _Total | Total amount of all Page Files usage, in percentage.
VMGuest-net | % Bandwidth Used | _Total | Percentage of bandwidth of all network adapters that are currently being used.